Random notes & other stuff…

…about Linux, electronics, digital photography, whatever…
Icône RSS Icône Accueil
  • Conditionnement de signal piezo

    Posté le 16th décembre 2009 leucos 5 commentaires

    (an english translation for this article is available here)

    AVERTISSEMENT : la diode Schottky Bat85 utilisée ici a un Vrrm trop bas pour les piezos  ! Utilisez une diode qui peut supporter au moins 200V Vrrm ! Thanks Alan for spotting this.

    Les transducteurs Piezo sont très courants, ne coutent rien, et peuvent se révéler d’excellent capteurs : son, choc, vibrations; tant que quelque chose « bouge » suffisamment ou fait du bruit, un capteur piézo peut être intéressant.

    En revanche, le signal généré par ces petites bêtes n’est pas très amical pour l’amateur d’électronique digitale : en gros, c’est une sinusoïde qui s’aplatit avec le temps. Par ailleurs, le signal se promène souvent dans les quartiers mal fréquentés des tensions négatives, ce qui n’est pas très agréable pour la plupart des chips et µcontrolleurs utilisés en électronique digitale. Par exemple, la datasheet de l’ATMega 168 (et c’est pareil pour la plupart des µ 8 bits d’atmel) indique que la tension appliquée à n’importe quelle patte doit se trouver entre -0.5V et VCC+0.5V. Les transducteurs piézo peuvent allègrement dépasser ces limites.

    Dans la capture ci-dessous, la tension lue aux bornes du piézo descend jusqu’à -52V et monte jusqu’à 9.2V. Ca fait plus de 60V crête à crête. Si on ne fait rien, le µ peut rapidement en faire une jaunisse… :

    Raw signal from piezo (2)

    Signal brut du piezo

    Dans la capture suivante, le signal descend d’abord à -20V, puis s’envole au dessus de 35V. Presque 60Vpp (crête à crête) ici aussi :

    Raw signal from piezo

    Signal brut du piezo (bis)

    Ce ne sont que des exemples. Je n’ai pas torturé ou frappé au marteau sur le piezo. Tapotez le juste avec un ongle et vous vous retrouverez en général avec des valeurs crête à crête énormes. L’autre problème c’est que ces valeurs sont imprévisible (les piézos le sont, mais pas la manière dont on les brutalise) : ça peut commencer par monter, puis descendre, puis monter, qui sait…

    Un petit coup de zoom montre l’effet « sinusoïde qui s’aplatit » que l’on observe en général après les plus gros pics de tension :

    Piezo signal close up

    Agrandissement du signal piezo

    Le conditionnement de signal est donc une étape obligatoire si l’on travaille en digital avec des piézos.

    Récapitulons ce que nous devons faire au signal pour le dompter :

    1. rendre le signal positif : la plupart du temps, les piezos sont lus par des CAN (convertisseurs analogiques/numériques), on veut donc des tensions positives
    2. restreindre son amplitude entre 0 et VCC, pour éviter que la tension n’affiche des valeurs effrayantes pour des µcontrolleurs et des CAN.
    3. modifier la forme du signal pour éviter les bosses, et le rendre plus propre et prévisible

    Tout cela n’est pas très compliqué à obtenir en fait. On va y aller en trois étapes, traitant respectivement les trois points ci-dessus :

    1. ajouter un redresseur simple alternance, pour garder la partie positive du signal
    2. ajout d’une diode zener pour éviter que les valeurs de signal soient supérieure à la tension d’avalanche de la zener
    3. ajouter un couple RC afin de filtrer les vaguelettes du signal

    Redresseur simple alternance

    En premier lieu, nous voulons rectifier le signal piezo, c’est à dire le rendre toujours positif. Pour cela, nous allons utiliser des diodes Schottky. Les diodes Schottky sont plus intéressantes car elles ont un seuil de tension directe (Vf) très bas (par comparaison avec des diodes standard), aux alentours de 0.3V.

    Piezo signal as seen after a full-wave rectifier

    Signal du piezo vu derrière un pont redresseur complet

    On peut se demander : pourquoi ne pas utiliser un pont redresseur complet à base de Schottky et rendre le signal tout entier positif (comme si l’on prenait la valeur absolue du signal) au lieu d’ignorer les tensions négatives ?

    Regardons les premières captures de signal brut à l’oscillo. Lorsque le signal change de signe, il le fait plutôt violemment, et son amplitude peut même être plus importante après le croisement du zéro qu’avant. Maintenant essayons d’appliquer la fonction mathématique ‘abs’ sur la courbe. On va se retrouver avec une courbe erratique : faible amplitude, plus haute, puis faible, etc… Même avec un filtrage poussé, ça sera difficile d’arriver à quelque chose de propre, et on aura toujours une coube sautillante, moins sauve que l’originale et complètement positive certes, ais difficilement exploitable.

    L’idée consiste donc à sacrifier la partie négative de la courbe pour obtenir un résultat plus lisse (le bug Agilent est offert gracieusement).

    Piezo signal rectified by only one Schottky diode

    Signal du piezo signal rectifié seulement par une diode Schottky

    En fait, on va faire un peu plus qu’un redresseur simple alternance. Si on ne met qu’une diode Schottky en série on se retrouvera avec une courbe ressemblant à elle de gauche. Nous pouvons voir qu’il reste une partie non négligeable du signal sous 0V, et dans notre circuit, ce n’est pas censé se produire.
    Même dans l’éventualité ou l’ADC s’en accommoderait, il ne ferait pas vraiment d’étincelles en mesurant une tension négative.

    Il y a surement une bonne raison pour que le signal se comporte de la sorte, mais je ne la connais pas. N’hésitez pas à commenter si vous avez la réponse.

    On doit donc se débarrasser de ce reliquat négatif et pour cela, nous allons utiliser une deuxième Schottky entre la masse et le signal. On ne garde que le signal positif, ca sera nettement plus simple comme ça.

    Piezo signal rectified by two Schottky

    Signal piezo rectifié par deux diodes Schottky

    Notre signal rectifié par les deux Schottky ressemble à la courbe de gauche (la courbe à éét décalée vers le bas pour des raisons esthétiques). On a encore quelques tensions négatives qui apparaissent, mais c’est presque négligeable maintenant. On peut se demander si ces -400mV ont un rapport avec le Vf de la diode.

    Même si l’échelle est différente, les vaguelettes semblent avoir disparues. C’est peut être du à la capacitance de la Schottky (14pF), qui, même si elle est faible, peut impacter les vaguelettes haute fréquence. Je n’ai pas eu le temps de vérifier.

    Maintenant nous devons limiter la tension maximale dans notre circuit, histoire de ne pas martyriser notre CAN.
    Diode Zener

    Comme vu plus haut, l’amplitude en tension est importante et on peut rapidement atteindre des valeurs inadaptées pour de l’électronique digitale. On doit donc dompter cette tension générée par le piézo. Les diodes Zener peuvent le faire : elles peuvent limiter la tension dans un circuit à une valeur fixe : quand la tension dans le circuit est supérieure à la tension d’avalanche de la Zener, elle devient passante, aidant ainsi à maintenant la tension sous ce seuil.

    Piezo signal, after Schottky rectifiers and Zener

    Signal du piezo signal, après les redresseurs Schottky et la  Zener

    En général, on doit ajouter une résistance en série avec la Zener afin de limiter le courant traversant la diode. Mais avec un piezo, ce n’est pas nécessaire, dans la mesure ou les courants en jeu sont très faibles.

    Après avoir ajouté notre Zener de 5.1v dans le circuit, la tension le sur le piézo ressemble à la capture de gauche.

    Vous pouvez torturer le piezo autant que vous voulez, vous ne pourrez pas dépasser le tension d’avalanche de la Zener.

    Si l’on en reste là, on aura pas mal de difficulté à savoir si le pizeo a été actionné une ou plusieurs fois. Nous allons devoir filtrer les pics afin d’obtenir une courbe plus docile.

    Filtrage du signal

    Ce signal peut être filtré par une cellule RC. Nous avons juste besoin de savoir combien de temps nous voulons voir la courbe durer afin d’ajuster les valeurs de R et de C. Pour mon application (batterie électronique), je voulais que le signal s’estompe en 10ms maximum. Comme l’on sait que le voltage descend à 10% de sa valeur initiale après t_(90%) = 2.2*R*C, on peut trouver le bon condensateur en fonction de la résistance ou vice-vesa.

    Imaginons que nous utilisons une résistance de 1MΩ, on devra utiliser un condensateur d’approximativement {10*10^-3}/{2.2*1*10^6} approx 4.5nF.

    Au final, on se retrouve avec ce circuit plutôt simple :PiezoFinalCircuit

    Et avec cette ravissante courbe :

    Finaly, a clean, ADC friendly signal

    Enfin, un signal propre, agréable en bouche pour le convertisseur analogique/digital

    J’espère que ce petit article vous aura aidé à dompter ces petite bêtes sauvages que sont les piézos. Attention toutefois, les piézos sont tous différents, et la taille compte. Alors expérimentez sur ces bases avant de graver en me croyant sur parole.

  • Configuration ADSL pour Free sur Cisco 1841

    Posté le 4th décembre 2009 leucos Pas de commentaires

    (an english translation for this article is here)

    Les clients de Free sont généralement contents… jusqu’a ce qu’ils aient besoin de support. C’est un problème avec tous les providers, mais chez Free en général, c’est gratiné.

    Quand vous vous abonez chez Free, vous recevez une belle Freebox : un equipement faisant office de modem DSL, routeur, de FXS pour brancher le téléphone et parfois plus si vous avez la chance d’avoir la TV et d’autres services.services.

    Mais quand vous ne voulez pas utiliser la FreeBox, ou qu’elle est morte, il y a des moyens alternatifs pour se connecter. Le plus simple c’est de trouver un modem DSL (un speedtouch par exemple), et d’utiliser un routeur pouvant faire du PPPoE (un Linksys WRT54GL + firmware tomato par exemple).

    Vous pouvez aussi faire du PPPoA si vous avez un routeur avec une interface ATM. La configuration ci dessous peut être utilisée sur un routeur Cisco 1841 avec une carte ATM pour se connceter chez Free. La conf est facilement adaptable à d’autre modèles, le changements se limitant souvent aux noms d’interfaces.

    Vous pouvez debugguer la connexion en tapant :

    debug ppp neg
    debug ppp auth

    Bonne chance.

    !
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname c1841-pppoa
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 0 CHANGE_YOUR_ENABLE_PASSWORD
    !
    no aaa new-model
    !
    resource policy
    !
    memory-size iomem 5
    mmi polling-interval 60
    !
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    ip subnet-zero
    ip cef
    !
    !
    no ip dhcp use vrf connected
    !
    ! Global pool for the LAN clients
    ip dhcp pool CLIENTS
    import all
    network 192.168.0.0 255.255.255.0
    default-router 192.168.0.254
    dns-server 192.168.0.254
    !
    ! Static assignements for specific clients
    ip dhcp pool pc1
    import all
    host 192.168.0.2 255.255.255.0
    client-identifier 0013.8dd7.2ada
    !
    ip dhcp pool pc2
    import all
    host 192.168.0.3 255.255.255.0
    client-identifier 0018.f327.3137
    !
    ip domain name whatever.it.is
    !
    ! Use ssh
    ! You need to issue
    ! crypto key generate rsa
    ! first
    ip ssh time-out 60
    ip ssh authentication-retries 2
    !
    ! Lets define some user
    username _CHANGE_USERNAME password à CHANGE_USERPASSWORD
    !
    !
    !
    interface Null0
    no ip unreachables
    !
    ! This is LAN side
    interface FastEthernet0/0
    description LAN connection
    ip address 192.168.0.254 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    duplex auto
    speed auto
    no cdp enable
    !
    interface FastEthernet0/1
    no ip address
    speed auto
    !
    ! This is the ATM interface
    ! We\'re doing PPPoA
    interface ATM0/0/0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    pvc 8/35
    ubr 160
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface BRI0/1/0
    no ip address
    shutdown
    !
    ! Dialer interface for PPP negotiation
    interface Dialer0
    ip address negotiated
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    no cdp enable
    ppp authentication chap pap callin
    ppp chap hostname 04XXXXXXXX@freeadsl
    ppp chap password 0 CHANGE_TO_YOUR_CHAP_PASS
    !
    ppp pap sent-username 04XXXXXXXX@freeadsl password 0 CHANGE_TO_YOUR_CHAP_PASS
    ! Required to get DNS servers
    ppp ipcp dns request
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer0
    !
    ! Required to act as a DNS server for the LAN clients
    ip dns server
    !
    ! Oh please no !
    no ip http server
    no ip http secure-server
    !
    ! Do some NAT for LAN clients
    ip nat inside source list 10 interface Dialer0 overload
    access-list 10 permit 192.168.0.0 0.0.0.255
    !
    control-plane
    !
    line con 0
    stopbits 1
    line aux 0
    line vty 0 4
    password 0 CHANGE_TO_SOME_PASS
    login local
    ! We just want ssh, not telnet
    transport input ssh
    !
    end
  • cats : un ‘cat’ pour le port série

    Posté le 30th novembre 2009 leucos 9 commentaires

    (an english version of this post is available here)

    Pour un futur projet, j’avais besoin de faire quelquechose du genre ‘cat /dev/leportserie’.

    Bien sur, avec cat, ça ne marche pas terrible. Alors voici ‘cats’, un ‘cat’ spécial port série.

    Ca a été écrit en 30 minutes, pas vraiment testé, mais à priori ça marche plutôt pas mal pour des opérations de lecture et d’écriture pas trop tordues.

    Par défaut, cats fonctionne en 9600 bauds.

    Compilation :

    gcc cats.c -o cats

    Exécution :

    ./cats /dev/ttyUSB0

    Example d’utilisation : attraper votre altitude depuis le GPS qui envoie des trames NMEA sur le port série :

    ./cats /dev/ttyUSB0 | grep GGA | cut -f 10 -d','

    cats habite chez  GitHub : http://github.com/leucos/cats

    Les retours, remarques et les engueulades sont les bienvenues.

    EDIT : nouvelle option pour cats (timestamping).

  • cats : serial port cat like utility

    Posté le 14th novembre 2009 leucos 1 commentaire

    (une version française de ce post est disponible ici)

    For an upcoming project, I needed to be able to ‘cat’ the serial port.
    So welcome ‘cats’, a serial cat wannabe.

    It’s very simple and not much tested for now, but works fine to read from the serial port. So if you give it a try, please send feedback.

    Default baud rate is 9600.

    Compile :

    gcc cats.c -o cats

    Run :

    ./cats /dev/ttyUSB0

    Usage exemple : grabbing your altitude from your serial connected NMEA GPS

    ./cats /dev/ttyUSB0 | grep GGA | cut -f 10 -d','

    Grab the source.

    EDIT : cats has now a GitHub home http://github.com/leucos/cats